Theme language

  • This topic is empty.
Viewing 12 posts - 16 through 27 (of 27 total)
  • Author
    Posts
  • #1761
    milos
    Moderator

    I tried again, but no luck… My computer shows your site normally, and it’s on IP address 46.231.24.66. But, when I try to access WordPress administration, I got 403 forbidden message. Perhaps your WordPress has some kind of protection.

    #1762
    milos
    Moderator

    I can’t see this page. I got this error:

    Forbidden

    You do not have permission to access this document.
    Web Server at giogantinu.com

    #1763
    Giona
    Participant

    Wow that’s really puzzling…did you empty your browser’s cache?
    I tried from another computer and simply see the login form

    #1764
    milos
    Moderator

    No, I can’t access your WordPress administration. I tried with several browsers. Maybe your host restricts access of your administration for unknown IP addresses.

    This is a good security measure, but this should be disabled temporarily so I can check your site.

    #1765
    Giona
    Participant

    That’s surely not the case, it’s a VPS and i’ve not activated any kind of IP restriction…

    #1766
    milos
    Moderator

    This is what I see when I go to your administration section.

    [attachment=3456]forbidden.jpg[/attachment]

    Front-end of your site is working normally.

    #1767
    Giona
    Participant

    What if i send you my .po file and you try to use it on your own version of the theme?

    #1768
    milos
    Moderator

    Sorry for late answering.

    Please zip your file and attach it here on the forum and I will try it.

    Thanks,
    Milos

    #1772
    Giona
    Participant
    milos wrote:
    Please zip your file and attach it here on the forum and I will try it.

    Thanks

    #1774
    milos
    Moderator

    Hi Giona,

    I finally found the problem(s). First of all, replace file contact.php with the attached file. Unzip it and upload to /wp-content/themes/wp_hot_wine (overwrite old). Here’s what else you should do:

    1. Edit functions.php file and comment/uncomment some lines at the top of the file, to look like this:

    Code:
    load_theme_textdomain(“hot_wine”, get_template_directory() . ‘/languages’);
    // $locale = get_locale();
    // $locale_file = get_template_directory_uri() . “/languages/$locale.php”;
    // if ( is_readable( $locale_file ) )
    // require_once( $locale_file );

    2. Our English .po file rename to wp_hot_wine.po and upload to folder /wp-content/themes/wp_hot_wine/languages (create this folder first).

    3. Create folder /wp-content/languages and create folder /wp-content/languages/themes. Your Italian language files rename to hot_wine-it_IT.po and hot_wine-it_IT.mo. Upload them both to the folder /wp-content/languages/themes

    4. Edit file wp-config.php and change line

    Code:
    define(‘WPLANG’, ”);

    to

    Code:
    define(‘WPLANG’, ‘it_IT’);

    Your translation should work after that.

    Thanks,
    Milos

    [attachment=3479]contact_2014-04-19.zip[/attachment]

    #1778
    Giona
    Participant

    Thanks a lot for your time Milos
    Unfortunately, i followed all your steps without success…

    #1792
    milos
    Moderator

    Impossible, you missed something, because Italian language from your file works fine on my server. You didn’t translate all the words though. Please check again.

Viewing 12 posts - 16 through 27 (of 27 total)
  • You must be logged in to reply to this topic.